Description: Description: Description: Description: Description: Description: Description: Description: Description: C:\Users\Graeme\AppData\Local\Microsoft\Windows\Temporary Internet Files\Content.Word\Candy Technote-small.jpg.Net Framework Installation

Introduction

Some features in Candy require the Microsoft .Net 3.5 Framework or .Net 4.0 Framework.
For now .
NET is an optional requirement. Candy will check the required .NET version before performing a particular function.

Versions of .Net included in OS

More recent versions of Windows have .Net preinstalled.

Vista has .NET 3.0 pre-installed.

Windows 7 has .NET 3.5 pre-installed.

Windows 7 SP1 has .NET 4.0 pre-installed.

Choosing the right .NET

If you have Windows XP SP3, Windows Vista SP1 or windows 7 it is recommended that you install .Net 4 framework.

Detailed .Net 4 download and installation here


If you have Windows XP SP2 or older or Windows Vista please install .net 3.5 SP1

Detailed .Net 3.5 SP1 download and installation here

Errors

 

Problem

Whilst attempting to import an XML file in Candy I get the following error message: ‘Could not load file or assembly System.Web, Version=4.0.0.0, Culture=neutral, PublicKey Token=b03f5f7f11d50a3a” or one of its dependencies. The system cannot find the file specified

Solution

Senario #1 (I have the full version of the .NET Framework 3.5 or  4.0 installed - My .NET framework installation needs to be repaired)

 

To do this follow these steps:

1.       Go to ‘Control Panel>Programs>Programs and Features’

2.       Search for “Microsoft .NET Framework”

3.       Right-click the entry and select “Uninstall/Change”

4.       Select “Repair .NET Framework to its original state”

5.       Click ‘Next’ and repair installation.

 

Scenario #2: (I have the .NET 4 Client Profile installed OR I don’t have .NET framework installed)

Download the full version of the .NET 4.0 Framework (HERE) and install it on your PC.